Installation du package tcolorbox — Les-mathematiques.net The most powerful custom community solution in the world

Installation du package tcolorbox

Je n'arrive pas à \usepackage "tcolorbox".
Lorsque j'inscris la commande dans mon préambule, j'obtiens, quoique je n'aie jamais écrit ces choses, que la compilation ne reconnaît pas \ExplSyntaxOn et Off.
Après avoir recherché sur le net, j'ai l'idée de faire précéder mon instruction de \usepackage{expl3}.
J'obtiens alors, mais elle seulement, l'erreur "l3backend.sty not found".
En la précédent également de \usepackage{l3baclend}, rien ne change.
Je ne sais plus quoi faire !

Réponses

  • La distribution est-elle à jour ?
  • @celine_L J'ai recherché dans la console MixTek "updates", que j'ai installées (une dizaine), mais il n'y avait rien qui s'appelle l3backend. C'est ce que vous vouliez dire ?
  • D'après cette page, il est censé y être.
  • Bonjour

     extrait de Miktex package Manager


  • Bonjour,
    OK, j'ai trouvé la liste que vous avez montré ci-dessus, et j'ai constaté que l3backend était bien installé.
    Cependant j'ai toujours ce message :

  • jcsjcs
    Modifié (25 Sep)
    Bonjour
     J'ai aussi la même remarque : l3backend.sty not found alors que je suis sûr qu'il est installé.
    En l'enlevant, cela compile.
    Une remarque \usepackage[utf8]{inputenc}  est inutile
  • @jcs
    En enlevant le package de Miktek ?
    Merci pour vos réponses et désolé pour mon incompétence totale...
  • Non, tout simplement en le commentant, c'est-à-dire en mettant un % devant la ligne dans le préambule.
  • @jcs Dans ce cas, on retombe sur l'erreur dont j'ai fait mention au début de ce fil : 


  • jcsjcs
    Modifié (25 Sep)
    Ce code  fonctionne que je compile avec latex ou avec xetex
    \documentclass[a4paper,12pt,twoside]{article}
    \usepackage[T1]{fontenc}
    \usepackage[french,english]{babel}
    \usepackage[a4paper]{geometry}
    \usepackage{tcolorbox}
    \usepackage{expl3}
    %\usepackage[dvips]{l3backend}
    
    \begin{document}
    
    \begin{tcolorbox}[colback=red!5!white,colframe=red!75!black,title=My nice heading]
    This is another \textbf{tcolorbox}.
    \tcblower
    Here, you see the lower part of the box.
    \end{tcolorbox}
    
    \end{document}
  • Pour moi non, le problème n'est pas résolu.
  • Je vous joins le message d'erreur de mon fichier final : 
  • Modifié (08:27)
    @celine_L Votre premier conseil était le meilleur : après réinstallation de MixTeX et TexMaker, le fameux problème pour l3backend a disparu. Merci beaucoup !
    Il me reste encore une erreur cependant, si quelqu'un sait à quoi elle correspond... (pas le "option clash" : celui-ci vient du package stix, seulement le "package minted error").
  • dpdp
    Modifié (08:40)
    Il faut compiler ton fichier avec l'option
    -shell-escape
    Tu peux aussi, si tu n'utilises pas minted (ce qui semble être le cas vu que tu ne comprends pas ce qu'il se passe), commencer par utiliser uniquement
    \usepackage[most]{tcolorbox}
    plutôt que
    \usepackage[all]{tcolorbox}
  • @dp Merci, ça fonctionne.
    Merci pour votre aide à tous !
Connectez-vous ou Inscrivez-vous pour répondre.
Success message!